Only Generates WebViewPage Template

Feb 6, 2014 at 11:03 AM
I'm trying to use this library to create razor email templates.

Even though I add @* Generator: Template *@ at the top of the razor file, when I right-click and select Run Custom Tool, it creates a class which inherits from WebViewPage, rather than from RazorTemplateBase.

Is there something I am missing here?

Cheers
Coordinator
Feb 6, 2014 at 2:44 PM
I have a working sample here. Can you try to compare and isolate difference?
Feb 6, 2014 at 10:08 PM
I had already downloaded and looked at that. I tried again this morning. The first attempt worked.

But then I made some changes and it reverted back to a WebViewPage.

Then, I deleted the cshtml file and started all over. But every time, it is a WebViewPage and not a RazorTemplateBase.

I've done this about 5 times over, copying your template text.
Coordinator
Feb 6, 2014 at 10:26 PM
Strange, I just tried and I don't see that (using latest VSIX & VS 2012 Update 4). When it regenerates the file, it's identical to what's in the repo except for the Runtime Version that gets updated.
Feb 7, 2014 at 6:35 AM
I'm using Visual Studio 2013 with v3 of Razor.

My apologies if you've stated somewhere that v3 is not supported.
Coordinator
Feb 7, 2014 at 6:36 PM
The version of Razor that your app is using should not be relevant here, since you are seeing the same issue with my test app. Right?

But I tried the generation with my test app in both 2012 and 2013, and was not able to repro the issue.